Fixing AppCode after Xcode Upgrade

Like a lot of people I’ve just updated my iPhone to run iOS 5.1 but it had knock on effect.

Firstly I could no longer run apps on my phone from Xcode without doing an upgrade to version 4.3.1, (fair enough the OS had changed).

However as Xcode is now distributed using the Apple App Store it’s location has changed so when opening AppCode I get an error that Xcode cannot be found.

I tried a few things like adding the VM options in the Info.plist file suggested and running xcode-select with a few different values such as /Applications, /Applications/Xcode.app…no joy.

Search the forums on the JetBrains web-site I found a post related to an earlier Xcode release and the magic command you need to run is:

xcode-select -switch /Applications/Xcode.app/Contents/Developer

I’m now up and running again, I also had to change the iOS simulator to use when running the app, but this setting is pretty obvious.

Advertisements